Unable to connect Graph accounts via hosted authentication
Incident Report for Nylas
Resolved
This incident has been resolved.
Posted Aug 30, 2022 - 00:17 PDT
Update
We have a fix ready and will be releasing this tomorrow (August 30, 2022). At this time, only graph authentication is affected, authentication using other providers does not have any issues.

Thank you for your patience.
Posted Aug 29, 2022 - 06:02 PDT
Identified
We have identified the root cause of the issue and are preparing the mitigation measures.
Posted Aug 26, 2022 - 07:32 PDT
Investigating
We are getting reports regarding accounts unable to connect using Graph as a provider in Nylas Hosted authentication. We are currently investigating this issue.

In the meantime, users might get the following error `No refresh token received from Microsoft.` while connecing accounts via Graph. The workaround is to use Native authentication.
Posted Aug 26, 2022 - 04:02 PDT
This incident affected: Nylas Application Services (API).