Issues authenticating Exchange accounts using a service account
Incident Report for Nylas
Resolved
This incident has been resolved.
Posted Apr 23, 2021 - 13:58 PDT
Identified
The issue has been identified and we are reaching out to affected customers with explanations in addition to a workaround they can use to prevent this situation from happening.
Posted Apr 22, 2021 - 14:13 PDT
Investigating
We are investigating issues with authenticating Exchange account using a service account. We are seeing accounts turning invalid right after authentication and also problems when using a different refresh token with the same OAuth client id. We’ll provide updates when we know more.
Posted Apr 21, 2021 - 10:51 PDT
This incident affected: API.