Internal API error when trying to load account endpoint and scheduler
Incident Report for Nylas
Resolved
The issue has been resolved and we had identified the root cause. It occurred due to an unsuccessful database migration that blocked some incoming requests for ~15 min before resolving the deadlock. We have moved the migration to the coming weekend and we'll post the maintenance schedule shortly.
Posted May 17, 2022 - 06:51 PDT
Monitoring
The issue has been mitigated. API calls and Scheduler are now loading correctly. We are investigating the root cause of this issue. For now, we'll keep it in monitoring.
Posted May 17, 2022 - 01:41 PDT
Investigating
We have noticed a spike in the Internal API error when trying to load the account endpoint and scheduler. We are investigating this at the moment and we'll provide further updates here.
Posted May 17, 2022 - 01:14 PDT
This incident affected: Nylas Application Services (API, Scheduler).