Upstream networking issue affecting many Nylas services including APIs and webhooks
Incident Report for Nylas
Resolved
This incident has been resolved, our Webhook and API services are all operating normally.
Posted Aug 31, 2021 - 17:15 PDT
Update
We are continuing to monitor this issue.
Posted Aug 31, 2021 - 14:27 PDT
Update
We have found that this incident is also affecting other API endpoints like "/send", "/calendars/free-busy", "/calendars/availability" and possibly more. The API calls may receive 500 status codes as the response directly. Also, some job-status made by other endpoints may also fail due to this issue.
Posted Aug 31, 2021 - 14:18 PDT
Identified
We have identified that our upstream cloud service provider AWS is having an ongoing incident with the network connectivity issue that is affecting our Webhook service in the US region, we are monitoring the status of this incident.
Posted Aug 31, 2021 - 12:21 PDT
Update
We are continuing to investigate this issue.
Posted Aug 31, 2021 - 11:46 PDT
Investigating
We have received reports of decreased number of webhook notifications being sent. We are currently looking into and we will be posting updates as they happen. Thank you for your patience.
Posted Aug 31, 2021 - 11:45 PDT
This incident affected: Nylas Application Services (API, Scheduler, Webhooks).