Nylas applications not active preventing API calls
Incident Report for Nylas
Postmortem

On April 4th at approximately 9:00PM EST, an automated billing script mistakenly froze approximately 50% of our customer applications, causing API calls using these application IDs to return "403 - This application has been disabled" errors. The issue was brought to our attention by customers at approximately 11:20 PM, and we immediately took action to unfreeze all accounts, completing the process by 12:00 AM. The root cause was an update to the script that did not properly account for changes in our billing system.

To prevent future incidents, we have improved our database to establish a "single source of truth" for paid status, added safety guards and monitoring to these scripts, implemented anomaly detection for all HTTP status codes (not just server errors), and set up a system to further monitor support ticket influx in a short period of time. We treat any situation where the customer notifies us of an incident before our systems alert us to the situation as a fundamental flaw, so we prioritize the remediation of these flaws at the highest level.

We apologize for any inconvenience caused and are committed to refining our systems and processes to provide the best possible service.

Posted Apr 12, 2023 - 11:00 PDT

Resolved
This incident has been resolved.
Posted Apr 04, 2023 - 21:58 PDT
Monitoring
We confirm all Nylas applications have now been properly re-activated. We will monitor for a while to ensure things stay stable.
Posted Apr 04, 2023 - 21:16 PDT
Identified
We are seeing some Nylas applications still being disabled. We are working on re-enabling them. Thank you for your patience.
Posted Apr 04, 2023 - 21:11 PDT
Monitoring
We have proceeded with re-activating all wrongly disabled Nylas applications. All Nylas API calls should be succeeding now. We will be monitoring to ensure all is back to normal.
Posted Apr 04, 2023 - 21:05 PDT
Identified
We are proceeding with re-activating the Nylas applications that have been wrongly disabled. API calls should start working again when your Nylas application gets re-activated.
Posted Apr 04, 2023 - 20:45 PDT
Investigating
We are receiving reports of Nylas applications being inactive and preventing API calls to succeed. We are looking into it.
Posted Apr 04, 2023 - 20:21 PDT
This incident affected: Nylas Application Services (API).