Some Google accounts encountering unexpected invalid sync state requiring re-authentication.
Incident Report for Nylas
Resolved
We are seeing full recovery from this incident. Impacted users have re-authenticated and sync is functioning normally for their accounts. In addition we have merged a code change to prevent future recurrences of this issue.
Posted Apr 26, 2022 - 14:32 PDT
Monitoring
To clarify on previous updates, we are only recommending customers reauthenticate for Google connected accounts that have unexpectedly entered a Stopped or Invalid state. We have identified the source of the issue and the scope of impact is limited only to a subset of all Google connected accounts. We are continuing to observe recovery as impacted accounts have been reauthenticated. We are also working on a code change to further mitigate the issue and prevent a recurrence. We will continue to monitor.
Posted Apr 26, 2022 - 11:17 PDT
Identified
We have identified a possible cause for the issue and are working on a fix to get this resolved.

Please reauthenticate the account for a quick resolution.

Thank you for your patience.
Posted Apr 26, 2022 - 08:20 PDT
Investigating
We have identified that some Google accounts have started falling out of authentication. Initial triage suggests that this is related to the deprecation of Google contacts API. We are investigating this at the moment and will publish further updates here.

To reconnect the affected accounts, we suggest re-authenticating them.
Posted Apr 26, 2022 - 03:56 PDT
This incident affected: Nylas Application Services (Sync Engine).