Elevated rate of 500 errors when authenticating both Gmail and Exchange accounts
Incident Report for Nylas
Resolved
We have identified the issue as a networking misconfiguration between our WAF provider and our load balancers. This incident is now resolved.
Posted Jun 15, 2021 - 17:24 PDT
Update
Our upstream provider is still investigating this issue and we are waiting to hear back from them. Thank you for your enduring patience.
Posted Jun 14, 2021 - 13:53 PDT
Update
We had to re-enable the infrastructure component we previously turned off as it was significantly affecting one of our customers. As a result, you might see the 500 errors we mentioned previously while authenticating Gmail and Microsoft accounts. The workaround remains to re-authenticate affected accounts as the issue is intermittent.
Posted Jun 10, 2021 - 16:18 PDT
Identified
We have temporarily fixed this issue and are still trying to investigate the root cause with our upstream provider. We are thanking you for your continued patience.
Posted Jun 10, 2021 - 08:57 PDT
Update
We are escalating this issue to one of our upstream providers. In the meantime, end-users not able to authenticate can retry as the problem is intermittent. Thank you for your patience.
Posted Jun 09, 2021 - 09:03 PDT
Investigating
We have received reports of 500 errors during authentication with the following error messages:

- No access token received from Google
- Couldn't exchange OAuth code for a Microsoft refresh token.

We are currently investigating this issue.
Posted Jun 08, 2021 - 20:26 PDT
This incident affected: Nylas Application Services (API).