Elevated rate of 404 errors on GET /messages/<message id> endpoint for Microsoft Exchange / Office 365 accounts
Incident Report for Nylas
Resolved
This incident has been resolved.
Posted Jul 13, 2023 - 11:01 PDT
Monitoring
Deployment is complete and and we are monitoring the results.
Posted Jul 13, 2023 - 10:36 PDT
Update
Deployment is 75% done and we confirm we are seeing the error rate decreasing.
Posted Jul 13, 2023 - 10:34 PDT
Update
The deployment is underway. You should see an improvement as hosts in our API fleet are getting updated with the new build. We are currently 10% done and we will keep you posted on the deployment progress.
Posted Jul 13, 2023 - 09:36 PDT
Identified
We have identified the issue and we are preparing a deployment with a fix.
Posted Jul 13, 2023 - 08:42 PDT
Update
Right now the issue seems specific to Microsoft Exchange accounts. We are still looking into it.
Posted Jul 13, 2023 - 08:11 PDT
Investigating
We are currently investigating this issue.
Posted Jul 13, 2023 - 07:53 PDT
This incident affected: Nylas Application Services (API).