API Degredation
Incident Report for Nylas
Resolved
All endpoints, including the handful of accounts impacted by sending issues, have been restored to normal operational status.
Posted Mar 14, 2019 - 12:15 PDT
Update
Sending errors have been fixed. Some accounts were using a temporarily misconfigured database. We're continuing to monitor the situation.
Posted Mar 14, 2019 - 12:10 PDT
Update
We are still seeing a few accounts having issues sending mail and are investigating those.
All other endpoints appear to be fully operational and have remained steady during overnight obeservation.
Posted Mar 14, 2019 - 11:55 PDT
Monitoring
API host has once again been restored. There appear to be certain accounts under certain circumstances that can degrade a single API box temporarily. We are beginning a deeper root cause analysis into these particular accounts causing this behavior.
Posted Mar 13, 2019 - 18:04 PDT
Investigating
Some of our API servers have returned to a degraded state. We are continuing to investigate why these API servers are intermittently degrading.
Posted Mar 13, 2019 - 17:17 PDT
Monitoring
API success and latency have returned to normal. We are continuing to monitor the situation.
Posted Mar 13, 2019 - 15:50 PDT
Investigating
We are seeing some problematic API hosts resurfacing and are continuing to investigate.
Posted Mar 13, 2019 - 15:31 PDT
Monitoring
The host has been restored to operational status. We are continuing to monitor API performance.
Posted Mar 13, 2019 - 14:14 PDT
Identified
We've identified an API host that has some stuck processes. We're working now to restore that host.
Posted Mar 13, 2019 - 14:11 PDT
Investigating
We're currently investigating a minor API degradation across a few API hosts.
Posted Mar 13, 2019 - 14:08 PDT
This incident affected: Nylas Application Services (API).