Accounts not synchronizing
Incident Report for Nylas
Resolved
This incident has been resolved.
Posted Feb 02, 2023 - 17:06 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 02, 2023 - 16:39 PST
Update
The script we are running is 100% done.
Posted Feb 02, 2023 - 16:39 PST
Update
The script we are running is 80% done.
Posted Feb 02, 2023 - 14:41 PST
Update
The script we are running is 40% done.
Posted Feb 02, 2023 - 14:02 PST
Update
The script we are running is 20% done.
Posted Feb 02, 2023 - 13:08 PST
Investigating
We have identified a possible cause and are investigating the solution.

If the account is GMAIL the dashboard sync state state is not accurate. Please use the Account Management endpoint to see the account sync state. https://developer.nylas.com/docs/api/#get/a/client_id/accounts

For Microsoft and IMAP there is a workaround you can restart the affected account by using the "Pause Sync" / "Retry Sync" button on the Nylas Dashboard (https://dashboard.nylas.com/).

If the account is invalid then none of the above will work.
Posted Feb 02, 2023 - 12:33 PST
Identified
We are running a script to fix all the affected accounts. We will keep you posted when it's done. Thank you for your continued patience.
Posted Feb 02, 2023 - 12:25 PST
Update
We are continuing to investigate this issue.

Take note that as a workaround you can restart the affected account by using the "Pause Sync" / "Retry Sync" button on the Nylas Dashboard (https://dashboard.nylas.com/).
Posted Feb 02, 2023 - 11:59 PST
Investigating
We are receiving reports of accounts not synchronizing properly. We are looking into it.
Posted Feb 02, 2023 - 11:18 PST
This incident affected: Nylas Application Services (Sync Engine).