Misleading Account Statuses
Incident Report for Nylas
Resolved
We have rolled out a new heartbeat-based service that monitors the true status of accounts. The new Nylas Dashboard now uses this heartbeat service. Under initial investigation this service returns a more reliable indication into the current status of accounts.

There are currently 3 statuses that the dashboard will display. There are ongoing plans to add additional granularity to those statuses. For now if an account is "Running" that means that each and every folder of the account is reporting in heartbeats to our service. If an account is "Partial" that means at least one (but not all) folders have missed a heartbeat for some reason. This can happen due to transient errors, due to incompatibilities with the provider, or due to other unknown reasons. There are plans to expose more underlying detail into "Partial" states. Finally the "Stopped" state means zero folders have reported in a heartbeat. The most common reason this happens is because we can no longer properly authenticate with the end account. Users may have changed their passwords or revoked access. It can also happen due to unforseen provider errors or sync bugs. There are plans to expose more details into why an account is "stopped".
Posted Nov 03, 2017 - 12:12 PDT
Update
Another issue currently affecting the Nylas Dashboard is some accounts (usually newly added ones) fail to show up in the Dashboard, or show up after some delay. We're continuing to work on systemic fixes for our Heartbeat service as well as making sure all syncing accounts show up quickly.
Posted Oct 16, 2017 - 09:50 PDT
Update
The account statuses on the new Nylas Developer Dashboard rely on a new and experimental Heartbeat service. Our engineers have been continuing to diagnose systematic fixes to make that system a more accurate reflection of the actual underlying sync status. Until we can guarantee that the new Heartbeat service reliably lines (and ideally exceeds) our old reporting mechanisms, there may be inconsistencies in the statuses being displayed by the new Nylas Developer Dashboard.
Posted Oct 03, 2017 - 12:00 PDT
Identified
The list of account statuses is currently misleading on the new Nylas Developer Dashboard only (https://dashboard.nylas.com). Many accounts are incorrectly marked "Stopped" when they are actually running. This is due to an ongoing error in our status reporting system.

The old Nylas Developer Dashboard (https://developer.nylas.com) has more accurate account statuses.

We have identified issues in the new service we're using to report stauses and are actively working on fixing this now.
Posted Sep 14, 2017 - 17:28 PDT