Nylas Mail Login, Identity & Billing services degraded performance
Incident Report for Nylas
Resolved
Service has been fully restored.
Posted Apr 18, 2017 - 08:26 PDT
Monitoring
We've successfully added more capacity. 502 error rates have dropped off. We're continuing to monitor as the load rebalances itself.
Posted Apr 18, 2017 - 08:14 PDT
Identified
Due to the Nylas Mail 2.0 release, a large and sudden influx of new signups is adding a large amount of stress to the signup servers. These servers also now vend information about Nylas ID to each connected client further adding to the load.

The servers initially didn't look maxed out sitting at 60% capacity. Upon further investigation it appears they were underutilized on workers. We're adding more capacity now.
Posted Apr 18, 2017 - 07:32 PDT
Investigating
We're currently investigating why billing.nylas.com is returning elevated 502 errors
Posted Apr 18, 2017 - 07:30 PDT