US - Increase of 504 errors with “Unknown connection error” on the /send endpoint for IMAP accounts
Incident Report for Nylas
Resolved
We continue to see the impacted customers' errors at normal levels, so we are marking this incident as resolved.
Posted Feb 19, 2024 - 17:20 PST
Monitoring
As of 9:00 PM UTC, the error rate has returned to normal levels. We have confirmed that this was only impacting a handful of customers using specific "custom IMAP" servers. We are marking this incident as mitigated while we continue to monitor and test.

https://developer.nylas.com/docs/api/supported-providers/
Posted Feb 19, 2024 - 16:00 PST
Update
We are still engaged with our infrastructure provider to find the root cause and why it is still primarily impacting a single customer. We will continue to post regular updates.
Posted Feb 19, 2024 - 14:00 PST
Update
We remain in ongoing collaboration with our infrastructure provider, closely keeping tabs on the situation at hand. The issue is currently contained within a specific scope, and our team is diligently working to expedite its resolution.
Posted Feb 19, 2024 - 13:05 PST
Update
We are still actively collaborating with our infrastructure provider and maintaining vigilant oversight of the ongoing situation. The problem is confined to a specific scope, and our team is dedicated to swiftly addressing and resolving it. Regular updates will be communicated every hour to keep you informed of our progress.
Posted Feb 19, 2024 - 11:55 PST
Update
We are continuing to work with our infrastructure provider while closely monitoring the situation. While the issue remains limited in scope, we are working to resolve the issue as quickly as possible.
Posted Feb 19, 2024 - 11:18 PST
Update
We are continuing to work with our infrastructure provider while we monitor the situation. The issue remains limited. We are working to resolve the issue as quickly as possible.
Posted Feb 19, 2024 - 10:48 PST
Update
We are continuing to work with our infrastructure provider while monitoring the situation closely.
Posted Feb 19, 2024 - 10:16 PST
Update
After further investigation, this issue appears to be limited to a few customers for now, primarily impacting a single customer. We are continuing to work with our infrastructure provider while monitoring closely.
Posted Feb 19, 2024 - 09:48 PST
Update
After assessing and eliminating all potential causes from our side, we are waiting to hear back from our infrastructure provider to continue with next steps. We will continue to monitor closely and post updates.
Posted Feb 19, 2024 - 09:14 PST
Update
We are reaching out to our infrastructure provider to help us get better insights on the current issues.
Posted Feb 19, 2024 - 08:30 PST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2024 - 08:09 PST
Investigating
We are seeing an increase in 504 errors with “Unknown connection error” when IMAP accounts are attempting to send messages with the /send API endpoint. We are currently investigating this issue.
Posted Feb 19, 2024 - 07:43 PST
This incident affected: Nylas Application Services (API).